Install Requirements

From Sit
Jump to: navigation, search

Requirements

You'll need at least the following software in order to install run SiT.

  • A web server (Apache recommended)
  • PHP >= 5.1 (Released November 2005) 1, 2
  • MySQL >= 4.1

The following PHP extensions are also required.

  • MySQL
  • PCRE
  • Session
  • Zlib
  • xml
  • IMAP 3
  • php5-cli 4
  • mbstring
  • gd

The following PHP extensions are optional.

  • LDAP (Required if you want to use the LDAP feature)

The account used for MySQL will need to have the following permissions:

  • Alter
  • Create
  • Delete
  • Insert
  • Select
  • Update

Notes

1 If using SiT! v3.50 or v3.51 (only) do not use PHP version 5.2 or later if you intend to use IMAP, see bug 985. Later versions of SiT! are OK with PHP 5.2.

2 SiT! version v3.62 and earlier do not install cleanly on MySQL 5.5, v3.63 and later do support this

3 The PHP IMAP extension is still required when using POP or other methods of incoming mail

4 The scheduler needs this, unless you are an advanced user and know how to do this differently. This package requirement differs from dist to dist, as some php packages comes with the cli module built-in


Personal tools
project